// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(vue? d[ée]gag[ée]|vue? (d'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)").unwrap();
let string = "avec vue dégagée
avec vue degagee
superbe vue dégagée
une belle vue dégagée
bénéficient d'une vue dégagée
terrasse offrant une vue dégagée
terrasse privative avec vue dégagée
terrasses avec vue dégagée
bureaux avec vue dégagée
bénéficie en façade d'une vue dégagée
surface bénéficie une vue dégagée
vue dégagée et sans vis à vis
rdc lumineux sans vis à vis
local sans vis a vis
avec une vue d'exception
avec une vue dexception
vue exceptionnelle
offrent une vue panoramique
lumineux vue panoramique
bénéficie d’une vue panoramique
dispose d'une vue panoramique
offre une vu panoramique
rooftop paysagé avec vue panoramique
vue 360° en rooftop";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}