import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(vue? d[ée]gag[ée]|vue? (d'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)";
final String string = "avec vue dégagée\n"
+ "avec vue degagee\n\n"
+ "superbe vue dégagée\n"
+ "une belle vue dégagée\n"
+ "bénéficient d'une vue dégagée\n"
+ "terrasse offrant une vue dégagée\n"
+ "terrasse privative avec vue dégagée\n"
+ "terrasses avec vue dégagée\n"
+ "bureaux avec vue dégagée\n"
+ "bénéficie en façade d'une vue dégagée\n"
+ "surface bénéficie une vue dégagée\n\n"
+ "vue dégagée et sans vis à vis\n"
+ "rdc lumineux sans vis à vis\n"
+ "local sans vis a vis\n\n"
+ "avec une vue d'exception\n"
+ "avec une vue dexception\n"
+ "vue exceptionnelle\n\n"
+ "offrent une vue panoramique\n"
+ "lumineux vue panoramique\n"
+ "bénéficie d’une vue panoramique\n"
+ "dispose d'une vue panoramique\n"
+ "offre une vu panoramique\n"
+ "rooftop paysagé avec vue panoramique\n\n"
+ "vue 360° en rooftop";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}