# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{1,2}[\/][0-9]{1,2}[\/][0-9]{1,4}) ([0-9]{1,2}:[0-9]{1,2}) - ([a-z0-9 \S]+?:)([a-z0-9 \S]+?\n)"
test_str = ("25/03/2017 09:32 - Diego Rhoger criou o grupo \"CerradoValley\"\n"
"27/04/2017 15:42 - Você entrou usando o link de convite deste grupo\n"
"27/04/2017 15:43 - +55 61 9332-2990: Valeu 👍🏻\n"
"27/04/2017 15:43 - Fabiano S Figueiredo: 🙃👍\n"
"27/04/2017 15:43 - Dartagnan Sabino Antunes Oliveira entrou usando o link de convite deste grupo\n"
"27/04/2017 15:44 - Fabiano S Figueiredo: e aí gente, tudo bem?\n"
"27/04/2017 15:44 - Fabiano S Figueiredo: Onde e como saber quem é quem? :D\n"
"27/04/2017 15:44 - +55 61 9332-2990: No decorrer das conversas vc vai conhecendo o pessoal rs\n"
"27/04/2017 15:45 - Fabiano S Figueiredo: né? :)\n"
"27/04/2017 15:45 - +55 61 9869-0018: é a única forma\n"
"27/04/2017 15:45 - +55 61 9869-0018: e ir aos meetups da vida\n"
"27/04/2017 15:46 - Fabiano S Figueiredo: Jóia. E normalmente o que é discutido aqui?\n"
"27/04/2017 15:55 - +55 61 9332-2990: Discutimos sobre mercado, economia, startups, comportamento empreendedor\n"
"27/04/2017 15:55 - +55 61 9332-2990: E as vezes a gente se espanca em assuntos de religiao e política\n"
"27/04/2017 15:55 - +55 61 9332-2990: As tudo fica bem depois\n"
"27/04/2017 15:56 - Fabiano S Figueiredo: Massa!!\n"
"27/04/2017 15:56 - +55 61 9332-2990: @556181302875 apresenta aí sua startup cara com poucas palavras\n"
"27/04/2017 15:56 - Fabiano S Figueiredo: Legal!!\n"
"27/04/2017 15:56 - +55 61 9332-2990: E manda o vídeo tbm rs\n"
"27/04/2017 15:56 - +55 61 9332-2990: Bota aí pra colher a opinião da gakera\n"
"27/04/2017 15:57 - +55 61 9332-2990: A minha vc já tem 👍🏻\n"
"27/04/2017 15:57 - Fabiano S Figueiredo: Qual é a do Vídeo?\n"
"27/04/2017 15:57 - +55 61 9332-2990: É pro @556181302875 rs\n"
"27/04/2017 15:57 - Fabiano S Figueiredo: Ahh!! ups!\n"
"27/04/2017 16:01 - Dartagnan Sabino Antunes Oliveira: Boa tarde Galera! Sou o Dartagnan, analista e desenvolvedor de sistemas.\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.