#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9]{1,2}[\/][0-9]{1,2}[\/][0-9]{1,4}) ([0-9]{1,2}:[0-9]{1,2}) - ([a-z0-9 \S]+?:)([a-z0-9 \S]+?\n)"
Local $sString = "25/03/2017 09:32 - Diego Rhoger criou o grupo "CerradoValley"" & @CRLF & _
"27/04/2017 15:42 - Você entrou usando o link de convite deste grupo" & @CRLF & _
"27/04/2017 15:43 - +55 61 9332-2990: Valeu 👍🏻" & @CRLF & _
"27/04/2017 15:43 - Fabiano S Figueiredo: 🙃👍" & @CRLF & _
"27/04/2017 15:43 - Dartagnan Sabino Antunes Oliveira entrou usando o link de convite deste grupo" & @CRLF & _
"27/04/2017 15:44 - Fabiano S Figueiredo: e aí gente, tudo bem?" & @CRLF & _
"27/04/2017 15:44 - Fabiano S Figueiredo: Onde e como saber quem é quem? :D" & @CRLF & _
"27/04/2017 15:44 - +55 61 9332-2990: No decorrer das conversas vc vai conhecendo o pessoal rs" & @CRLF & _
"27/04/2017 15:45 - Fabiano S Figueiredo: né? :)" & @CRLF & _
"27/04/2017 15:45 - +55 61 9869-0018: é a única forma" & @CRLF & _
"27/04/2017 15:45 - +55 61 9869-0018: e ir aos meetups da vida" & @CRLF & _
"27/04/2017 15:46 - Fabiano S Figueiredo: Jóia. E normalmente o que é discutido aqui?" & @CRLF & _
"27/04/2017 15:55 - +55 61 9332-2990: Discutimos sobre mercado, economia, startups, comportamento empreendedor" & @CRLF & _
"27/04/2017 15:55 - +55 61 9332-2990: E as vezes a gente se espanca em assuntos de religiao e política" & @CRLF & _
"27/04/2017 15:55 - +55 61 9332-2990: As tudo fica bem depois" & @CRLF & _
"27/04/2017 15:56 - Fabiano S Figueiredo: Massa!!" & @CRLF & _
"27/04/2017 15:56 - +55 61 9332-2990: @556181302875 apresenta aí sua startup cara com poucas palavras" & @CRLF & _
"27/04/2017 15:56 - Fabiano S Figueiredo: Legal!!" & @CRLF & _
"27/04/2017 15:56 - +55 61 9332-2990: E manda o vídeo tbm rs" & @CRLF & _
"27/04/2017 15:56 - +55 61 9332-2990: Bota aí pra colher a opinião da gakera" & @CRLF & _
"27/04/2017 15:57 - +55 61 9332-2990: A minha vc já tem 👍🏻" & @CRLF & _
"27/04/2017 15:57 - Fabiano S Figueiredo: Qual é a do Vídeo?" & @CRLF & _
"27/04/2017 15:57 - +55 61 9332-2990: É pro @556181302875 rs" & @CRLF & _
"27/04/2017 15:57 - Fabiano S Figueiredo: Ahh!! ups!" & @CRLF & _
"27/04/2017 16:01 - Dartagnan Sabino Antunes Oliveira: Boa tarde Galera! Sou o Dartagnan, analista e desenvolvedor de sistemas." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")