$re = '/^([^\d]*)(\d+)/m';
$str = 'chapter02pt2.xhtml
chapter02pt2.xhtml
02_FM.xhtml
03_Title.xhtml
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);