using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\d]*)(\d+)";
string input = @"chapter02pt2.xhtml
chapter02pt2.xhtml
02_FM.xhtml
03_Title.xhtml
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}