re = /^(?<sign>[+-])?\d+(?:\.?\d+)?(?<percent>%)?$/m
str = '50
-50
+50
50%
+50%
-50%
50.50.50
+-50%
-50.%
4.%
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end