#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<sign>[+-])?\d+(?:\.?\d+)?(?<percent>%)?$"
Local $sString = "50" & @CRLF & _
"-50" & @CRLF & _
"+50" & @CRLF & _
"50%" & @CRLF & _
"+50%" & @CRLF & _
"-50%" & @CRLF & _
"50.50.50" & @CRLF & _
"+-50%" & @CRLF & _
"-50.%" & @CRLF & _
"4.%" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")