$re = '/.*(?=s\d{1,2}e\d{1,2})(s\d{1,2}e\d{1,2}).*(\..*)/mi';
$str = 'doctor.who.2005.s05e10.720p.bluray.h264.mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);