using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?=s\d{1,2}e\d{1,2})(s\d{1,2}e\d{1,2}).*(\..*)";
string input = @"doctor.who.2005.s05e10.720p.bluray.h264.mkv";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}