// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)jdbc:(.*?):[\/@]+(.*?):([0-9]+);(?:databaseName)=([a-z_]+)").unwrap();
let string = "jdbc:sqlserver://vmsqlentpag03:1433;databaseName=SEPM_PRD;integratedSecurity=true;encrypt=true;trustServerCertificate=true;domain=HERSHEY";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}