$re = '/jdbc:(.*?):[\/@]+(.*?):([0-9]+);(?:databaseName)=([a-z_]+)/mi';
$str = 'jdbc:sqlserver://vmsqlentpag03:1433;databaseName=SEPM_PRD;integratedSecurity=true;encrypt=true;trustServerCertificate=true;domain=HERSHEY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);