$re = '/^(([[:xdigit:]]){2}[:\-\.]){5}([[:xdigit:]]){2}$/m';
$str = '11:22:33:44:55:aa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);