package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([[:xdigit:]]){2}[:\-\.]){5}([[:xdigit:]]){2}$`)
var str = `11:22:33:44:55:aa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}