$re = '/\s(?!])\K[\S;]*/';
$str = '[Vivid-Asenshi] Violet Evergarden - 02 [53E58502].mkv';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);