using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?!])\K[\S;]*";
string input = @"[Vivid-Asenshi] Violet Evergarden - 02 [53E58502].mkv";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}