re = /^([MTWFS][\w]{2},) (\d{2}) ([A-Z][a-z]{2}) (\d{4}) (\d{2}:\d{2}:\d{2}) ([A-Z]{3,}|[+\-]\d+)$/m
str = 'Tue, 04 Jun 2024 04:02:01 GMT
Tue, 04 Jun 2024 04:02:01 +0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end