const regex = /^([MTWFS][\w]{2},) (\d{2}) ([A-Z][a-z]{2}) (\d{4}) (\d{2}:\d{2}:\d{2}) ([A-Z]{3,}|[+\-]\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([MTWFS][\\w]{2},) (\\d{2}) ([A-Z][a-z]{2}) (\\d{4}) (\\d{2}:\\d{2}:\\d{2}) ([A-Z]{3,}|[+\\-]\\d+)$', 'gm')
const str = `Tue, 04 Jun 2024 04:02:01 GMT
Tue, 04 Jun 2024 04:02:01 +0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}