// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<!-- OPTIONAL -->(.*?)<!-- OPTIONAL END -->").unwrap();
let string = "<p>something</p>
<!-- OPTIONAL -->
<p class=\"sdf\"> some text</p>
<p> some other text</p>
<!-- OPTIONAL END -->
<p>The end</p>
<p>something</p>
<!-- OPTIONAL -->
<p class=\"sdf\"> some text</p>
<p> some other text</p>
<!-- OPTIONAL END -->
<p>The end</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}