re = /<!-- OPTIONAL -->(.*?)<!-- OPTIONAL END -->/
str = '<p>something</p>
<!-- OPTIONAL -->
<p class="sdf"> some text</p>
<p> some other text</p>
<!-- OPTIONAL END -->
<p>The end</p>
<p>something</p>
<!-- OPTIONAL -->
<p class="sdf"> some text</p>
<p> some other text</p>
<!-- OPTIONAL END -->
<p>The end</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end