re = /(?x)^
([\d-]+)\s+([\d:.]+)\s+
(\d+)\s\s(\d+)\s
([VDIWEF])\s(.*?):
(.*)
$/m
str = '06-09 17:48:08.555 1644 5345 V EXAPLE_TAG: hello I am a log1
06-09 17:48:08.555 1644 5345 D EXAPLE_TAG: hello I am a log2
06-09 17:48:08.555 1644 5345 I EXAPLE_TAG: hello I am a log3
06-09 17:48:08.555 1644 5345 W EXAPLE_TAG: hello I am a log4
06-09 17:48:08.555 1644 5345 E EXAPLE_TAG: hello I am a log5
06-09 17:48:08.555 1644 5345 F EXAPLE_TAG: hello I am a log6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end