using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)^
([\d-]+)\s+([\d:.]+)\s+
(\d+)\s\s(\d+)\s
([VDIWEF])\s(.*?):
(.*)
$";
string input = @"06-09 17:48:08.555 1644 5345 V EXAPLE_TAG: hello I am a log1
06-09 17:48:08.555 1644 5345 D EXAPLE_TAG: hello I am a log2
06-09 17:48:08.555 1644 5345 I EXAPLE_TAG: hello I am a log3
06-09 17:48:08.555 1644 5345 W EXAPLE_TAG: hello I am a log4
06-09 17:48:08.555 1644 5345 E EXAPLE_TAG: hello I am a log5
06-09 17:48:08.555 1644 5345 F EXAPLE_TAG: hello I am a log6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}