re = /^(?<fulldomain>(?<protocol>[a-z]{2,6}):\/\/(?:((?<subdomain>[a-z0-9\-\.]*\.){0,99})(?<domain>[a-z\-0-9]{1,100})\.(?<extension>[a-z]{1,10})|(?<ipaddress>(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})(?:\.(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})){3})|(?<localhost>localhost))(?<port>\:[0-9]{1,6}){0,1})\/?(?<filepath>(?<path>[a-z0-9\-_%]{1,20}\/{1}){0,}(?<filename>[a-z0-9\-_]{1,20}\.[a-z0-9]{2,6}){0,1}){0,1}(?<route>(\/[a-z_0-9\-_]{1,20}){1,}){0,10}(?<query>\?[a-z0-9%\+_\-&=\.@\!,\:]{0,200}){0,1}$/m
str = 'https://test.example.com:3000/path/to/page?q=1234&a=b&d=e
https://lots.of.subs.test.example.com:3000/path/to/page?q=1234&a=b&d=e
http://192.168.100.0:8080/path/to/page?q=123
http://localhost:3000/path/to/page?q=123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end