# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<fulldomain>(?<protocol>[a-z]{2,6}):\/\/(?:((?<subdomain>[a-z0-9\-\.]*\.){0,99})(?<domain>[a-z\-0-9]{1,100})\.(?<extension>[a-z]{1,10})|(?<ipaddress>(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})(?:\.(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})){3})|(?<localhost>localhost))(?<port>\:[0-9]{1,6}){0,1})\/?(?<filepath>(?<path>[a-z0-9\-_%]{1,20}\/{1}){0,}(?<filename>[a-z0-9\-_]{1,20}\.[a-z0-9]{2,6}){0,1}){0,1}(?<route>(\/[a-z_0-9\-_]{1,20}){1,}){0,10}(?<query>\?[a-z0-9%\+_\-&=\.@\!,\:]{0,200}){0,1}$"
test_str = ("https://test.example.com:3000/path/to/page?q=1234&a=b&d=e\n"
"https://lots.of.subs.test.example.com:3000/path/to/page?q=1234&a=b&d=e\n"
"http://192.168.100.0:8080/path/to/page?q=123\n"
"http://localhost:3000/path/to/page?q=123\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.