const regex = new RegExp('(?:\\d{1,3})\\s+(?:Platform Alarm\\(\\d+\\))\\s+\\d+\\s+(\\d+).+(\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}).+nodeBId:(\\d+).+Office Name\\(Site\\)=([\\w_]+)', 'gm')
const str = `277 Platform Alarm(20420) 1337 198092557 User-defined dry contact alarm 8 Minor SubNetwork=75,MEID=5721,Equipment=1,Rack=1,SubRack=1,Slot=13 2021-06-21 04:27:39 U RNCId: 75; Dry contact ID: 6; Board serial number: 274808900275; U nodeBId:5721 Office ID(Site)=5721/Office Name(Site)=San_Telmo/Alarm Object Type=SDR/Alarm Object ID=5721/Alarm Object Name=San_Telmo/Board Type=SA 75-5721-1_1_13_1_198092557_6
12 Radio Controller(1701) 100001 41591 1615258887314 Processing Alarm 83886256 NodeB is out of service Critical SubNet(75)/ManagedElement(75)/Rack No.(1)/Shelf No.(1)/Board No.(8)/CPU No.(1) 2021-03-29 20:08:33 Alarm Object:NODEB; \\nNodeB ID:5433; \\nAlarm sub code:2; \\nIub Transport bearer type:IP V4 Bearer Type; \\nLink Number:1; \\nLink ID list:1126;\\nLogic Position:System No.:0,Module No.:7,Index:0; RNCSCB04 83886768 NCP link failure Office ID(Site)=5433/Office Name(Site)=Tariba/Alarm Object Type=NODEB/Alarm Object ID=5433/Alarm Object Name=Tariba/Board Type=CDR/APP Type=product:wcdma,wcdma/Object MOC=UIUBLINK/Object DN=SubNetwork=75,MEID=75,URncFunction=75,UIubLink=5433
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}