import Foundation
// WARNING: You included a flag that Swift doesn't support: U
// When this flag is set, it inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by '?'.
// As an alternative, this effect can also be achieved by setting a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
let pattern = #"function(.|\n)*{(.|\n)*if(.|\n)*function "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
onRenderComplete: function () {
pageData.orderingAll = viewModel.tabAllGrid.getOrdering();
if (app.session.features.openNotesAndMessagesFromList_VEA14870) {
$('#tabAllGrid .connectedMessageIcon').on('click', function (e) {
var $messages = $(e.target),
$row = $messages.parents('.gridRow'),
rowId = $row.data('row'),
rowData = $('#tabAllGrid').vismaGrid('getRowData', rowId);
postItMessageModal(rowData);
});
function postItMessageModal(data) {
var documentType = null;
var documentId = null;
var urls = data.invoiceUrl.split('/');
if (urls.length > 3 && urls[3]) {
documentType = urls[2];
var guidRegex = /^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$/;
if (urls[3].match(guidRegex)) {
documentId = urls[3];
} else {
documentId = urls[4];
}
}
app.shell.viewModel.commentViewModel.getMessagesForGivenDocument(documentType, documentId, false, true);
};
}
},
initialSelected: initialSelectedAll
};
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)