package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)function(.|\n)*{(.|\n)*if(.|\n)*function `)
var str = ` onRenderComplete: function () {
pageData.orderingAll = viewModel.tabAllGrid.getOrdering();
if (app.session.features.openNotesAndMessagesFromList_VEA14870) {
$('#tabAllGrid .connectedMessageIcon').on('click', function (e) {
var $messages = $(e.target),
$row = $messages.parents('.gridRow'),
rowId = $row.data('row'),
rowData = $('#tabAllGrid').vismaGrid('getRowData', rowId);
postItMessageModal(rowData);
});
function postItMessageModal(data) {
var documentType = null;
var documentId = null;
var urls = data.invoiceUrl.split('/');
if (urls.length > 3 && urls[3]) {
documentType = urls[2];
var guidRegex = /^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$/;
if (urls[3].match(guidRegex)) {
documentId = urls[3];
} else {
documentId = urls[4];
}
}
app.shell.viewModel.commentViewModel.getMessagesForGivenDocument(documentType, documentId, false, true);
};
}
},
initialSelected: initialSelectedAll
};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}