re = /(?<![:\/])\/\/.*$/m
str = '{ "a" : "boru", // comment
"b" : "https://www.example.com", // another comment
"c" : "file:///some.txt" // more comment
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end