$re = '/(?<![:\/])\/\/.*$/m';
$str = '{ "a" : "boru", // comment
"b" : "https://www.example.com", // another comment
"c" : "file:///some.txt" // more comment
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);