// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9a-zA-z]{10}\(\\x01[0-9]{1}\\x02([0-9]{2})\\x02[0-9]{2}\\n").unwrap();
let string = "
4nY6zVk61Z(\\x010\\x0205\\x0202\\n
4nY8GkxuEy(\\x010\\x0201\\x0202\\n
4nYA5W4GtJ(\\x010\\x0205\\x0202\\n
4nY6zVk61Z(\\x010\\x0205\\x0202\\n
4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n
4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n
\\x02([0-9]{2})\\x02";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}