const regex = /^[0-9a-zA-z]{10}\(\\x01[0-9]{1}\\x02([0-9]{2})\\x02[0-9]{2}\\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9a-zA-z]{10}\\(\\\\x01[0-9]{1}\\\\x02([0-9]{2})\\\\x02[0-9]{2}\\\\n', 'gm')
const str = `
4nY6zVk61Z(\\x010\\x0205\\x0202\\n
4nY8GkxuEy(\\x010\\x0201\\x0202\\n
4nYA5W4GtJ(\\x010\\x0205\\x0202\\n
4nY6zVk61Z(\\x010\\x0205\\x0202\\n
4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n
4nY8spkhEULA1701\\x0276\\x0276\\x011(\\x012(\\n
\\x02([0-9]{2})\\x02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}