re = /^[a-zA-Z0-9][\w\-\.]*(?<![^a-zA-Z0-9])@(?![^a-zA-Z0-9])(?:[\w\-]+(?<![^a-zA-Z0-9])\.)+[a-zA-Z]{2,}$/m
str = 'user@gmail.com
personal@corpmail.com
personal@sub.domain.com
user-name@mail.student
user.name@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end