const regex = /^[a-zA-Z0-9][\w\-\.]*(?<![^a-zA-Z0-9])@(?![^a-zA-Z0-9])(?:[\w\-]+(?<![^a-zA-Z0-9])\.)+[a-zA-Z]{2,}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9][\\w\\-\\.]*(?<![^a-zA-Z0-9])@(?![^a-zA-Z0-9])(?:[\\w\\-]+(?<![^a-zA-Z0-9])\\.)+[a-zA-Z]{2,}$', 'mg')
const str = `user@gmail.com
personal@corpmail.com
personal@sub.domain.com
user-name@mail.student
user.name@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}