use strict;
my $str = 'array();';
my $regex = qr/array\s*\(\s*([^)]*)\s*\)/mp;
my $subst = '[$1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";