package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)array\s*\(\s*([^)]*)\s*\)`)
var str = `array();`
var substitution = "[$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}