import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\S(?:\\s*.*?)>";
final String string = "<p class=\"MsoNormal\" style=\"line-height: normal; margin-bottom: 6pt;\" align=\"justify\">Les RPS conformément à la méthodologie, ne figurent pas dans cette analyse mais sont bien pris en compte. Il conviendra dans le cadre des RPS que l'outil peut être désactivé en dehors des heures normales de service (équilibre vie privée vie professionnelle).<br /></p>Rappels des modalités d'application des règles d’< ut< il>>isat< ion <i>ssues des </i>dispositions < générales décrites dans l’IN 7994<";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}