re = /(?P<full_name>(?P<fname>[firstname]{3,})\s\w*?(?P<lname>[lastname]{3,}))/mix
str = 'first last
name lastname
fname lname
namef namel
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end