const regex = new RegExp('(?P<full_name>(?P<fname>[firstname]{3,})\\s\\w*?(?P<lname>[lastname]{3,}))', 'gmi')
const str = `first last
name lastname
fname lname
namef namel
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}