const regex = /^(`{3}.*[\n\r][^]*?^`{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(`{3}.*[\\n\\r][^]*?^`{3})', 'gm')
const str = `Find: \`^(.*)\`
Replace: \`Prefix-\\1\`
\`\`\`
1
2
3
\`\`\`
Into:
\`\`\`
Prefix-1
Prefix-2
Prefix-3
\`\`\`
Thanks. That’s handy, but I’m not likely to remember it (regex not my thing), whereas an action can be named and easily run.
I’ve been thinking about this for while. It’s similar to other Drafts actions I’ve written, so I took some of that code and built [this](https://actions.getdrafts.com/a/17N).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}