package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(`{3}.*[\n\r][^]*?^`{3})`)
var str = `Find: \`^(.*)\`
Replace: \`Prefix-\1\`
\`\`\`
1
2
3
\`\`\`
Into:
\`\`\`
Prefix-1
Prefix-2
Prefix-3
\`\`\`
Thanks. That’s handy, but I’m not likely to remember it (regex not my thing), whereas an action can be named and easily run.
I’ve been thinking about this for while. It’s similar to other Drafts actions I’ve written, so I took some of that code and built [this](https://actions.getdrafts.com/a/17N).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}