re = /https?:\/\/\K((?:[^.\/]+\.)+[^\/]+)/
str = 'https://www.google.com/?gws_rd=ssl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end