$re = '/https?:\/\/\K((?:[^.\/]+\.)+[^\/]+)/';
$str = 'https://www.google.com/?gws_rd=ssl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);