re = /^(([0-9]){1,3})[.](([0-9]){1,3})[.](([0-9]){1,3})[.](([0-9]){1,3})$/m
str = '1
1.
1.1
1.1
1.1.
1.1.1
1.1.1.
1.1.1.1
1.1.1.1.
1.1.1.1.1
20
20.
20.20
20.20.
20.20.20
20.20.20.
20.20.20.20
20.20.20.20.
20.20.20.20.20
300
300.
300.300
300.300.
300.300.300
300.300.300.
300.300.300.300
300.300.300.300.
300.300.300.300.300
4000
4000.
4000.4000
4000.4000.
4000.4000.4000
4000.4000.4000.
4000.4000.4000.4000
4000.4000.4000.4000.
4000.4000.4000.4000.4000
ak</\';
1,1,1,1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end