#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([0-9]){1,3})[.](([0-9]){1,3})[.](([0-9]){1,3})[.](([0-9]){1,3})$"
Local $sString = "1" & @CRLF & _
"1." & @CRLF & _
"1.1" & @CRLF & _
"1.1" & @CRLF & _
"1.1." & @CRLF & _
"1.1.1" & @CRLF & _
"1.1.1." & @CRLF & _
"1.1.1.1" & @CRLF & _
"1.1.1.1." & @CRLF & _
"1.1.1.1.1" & @CRLF & _
"20" & @CRLF & _
"20." & @CRLF & _
"20.20" & @CRLF & _
"20.20." & @CRLF & _
"20.20.20" & @CRLF & _
"20.20.20." & @CRLF & _
"20.20.20.20" & @CRLF & _
"20.20.20.20." & @CRLF & _
"20.20.20.20.20" & @CRLF & _
"300" & @CRLF & _
"300." & @CRLF & _
"300.300" & @CRLF & _
"300.300." & @CRLF & _
"300.300.300" & @CRLF & _
"300.300.300." & @CRLF & _
"300.300.300.300" & @CRLF & _
"300.300.300.300." & @CRLF & _
"300.300.300.300.300" & @CRLF & _
"4000" & @CRLF & _
"4000." & @CRLF & _
"4000.4000" & @CRLF & _
"4000.4000." & @CRLF & _
"4000.4000.4000" & @CRLF & _
"4000.4000.4000." & @CRLF & _
"4000.4000.4000.4000" & @CRLF & _
"4000.4000.4000.4000." & @CRLF & _
"4000.4000.4000.4000.4000" & @CRLF & _
"ak</';" & @CRLF & _
"1,1,1,1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")