// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(^\s+(?P<att_name>[^\s]+)\s+(?P<att_value>[^\s{]+|"[^"]+?")\s?(?P<att_body>{[\s\S]+?})?)$"#).unwrap();
let string = "
rel_tgt_id 2
IncomingUser \"user1234 secret123456\"
GROUP access_group{
LUN 0 dev2-0
LUN 1 dev2-1
LUN 2 dev2-2
LUN 3 dev2-3
LUN 4 dev2-4
LUN 5 dev2-5
LUN 6 dev2-6
LUN 7 dev2-7
LUN 8 dev2-8
LUN 9 dev2-9
INITIATOR iqn.1994-09.org.freebsd:*
}
enabled 1
MaxSessions 10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}