re = /(^\s+(?P<att_name>[^\s]+)\s+(?P<att_value>[^\s{]+|"[^"]+?")\s?(?P<att_body>{[\s\S]+?})?)$/m
str = '
rel_tgt_id 2
IncomingUser "user1234 secret123456"
GROUP access_group{
LUN 0 dev2-0
LUN 1 dev2-1
LUN 2 dev2-2
LUN 3 dev2-3
LUN 4 dev2-4
LUN 5 dev2-5
LUN 6 dev2-6
LUN 7 dev2-7
LUN 8 dev2-8
LUN 9 dev2-9
INITIATOR iqn.1994-09.org.freebsd:*
}
enabled 1
MaxSessions 10
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end