#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:[0-9]{1,3}\.){3}[0-9]{1,3}).*(([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))"
Local $sString = "" & @CRLF & _
"IP address HW type Flags HW address Mask Device Ethernet interface VLAN ID" & @CRLF & _
"10.26.64.1 0x1 0x2 e0:97:96:bd:e6:48 * veip0.2" & @CRLF & _
"1.1.1.2 0x1 0x2 00:26:86:00:00:00 * br0" & @CRLF & _
"192.168.1.3 0x1 0x2 b8:27:eb:48:3d:e6 * br0 LAN3 0" & @CRLF & _
"" & @CRLF & _
"IPv6 Neighbor Table:" & @CRLF & _
"IPv6 address HW Address Device" & @CRLF & _
"fe80::9a97:d1ff:fe70:eeb6 98:97:d1:70:ee:b6 br0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")