// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?msu)\[(?P<key>.+?)(?:\s+(?P<settings>.*?))?\]").unwrap();
let string = "### The I_Soil System
The I-soil material model is a nonlinear hysteretic soil model that is based on the distributed
element models developed by [!citet](iwan1967on) and [!citet](chiang1994anew). In 1-D, this model takes
the backbone stress-strain curve and divides it into a set of elastic-perfectly plastic curves. The
total stress then is the sum of the stresses from the individual elastic-perfectly plastic curves.
The three dimensional generalization of this model is achieved using von-Mises failure criteria for
each elastic-perfectly plastic curve resulting in an invariant yield surfaces in three-dimensional
stress space like in [fig:yieldsurface] (after [!citet](chiang1994anew)).";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}