$re = '/(?:((?>.{1,48}(?:(?<=[^\S\r\n])[^\S\r\n]?|(?=\r?\n)|$|[^\S\r\n]))|.{1,48})(?:\r?\n)?|(?:\r?\n|$))/';
$str = '----+----1----+----2----+----3----+----4----+--8 *** Fonte tipo A com Página de Código pc850: À noite, vovô Kowalsky vê o ímã cair no pé do pingüim quêixoso e vovó põe açúcar no chá de tâmaras do jabuti feliz. ÁÉÍÓÚáéíóúçÇãõÃÕÊêÂâÔôÀà';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;