# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:((?>.{1,48}(?:(?<=[^\S\r\n])[^\S\r\n]?|(?=\r?\n)|$|[^\S\r\n]))|.{1,48})(?:\r?\n)?|(?:\r?\n|$))/$1\n/g;t' <<< "----+----1----+----2----+----3----+----4----+--8 *** Fonte tipo A com Página de Código pc850: À noite, vovô Kowalsky vê o ímã cair no pé do pingüim quêixoso e vovó põe açúcar no chá de tâmaras do jabuti feliz. ÁÉÍÓÚáéíóúçÇãõÃÕÊêÂâÔôÀà"